Jump to content
Bloaps

1st Generation iTouch

Recommended Posts

Hey,

I was recently given an iPod Touch which is 1st Generation. It's current Software Version is 1.1.5 and i'm wondering if it is possible to update or jailbreak past then, because it doesn't even have an App Store :)

If it can't, then there are no worries but if you can help then please ask for anymore information you may need :)

Thanks

Share this post


Link to post
Share on other sites

iOS 4 sadly doesn't support iPod Touch 1st generations any more. There are hardware difference between generations, iOS4 is 'too much' for 1st generation iPods.

 

Sorry to dissapoint you Bloaps. PS: Welcome to Geeksoup!

Share this post


Link to post
Share on other sites

You would need a new iPod Touch. You can pick them up cheaply nowadays, the one you have lacks the hardware for the latest firmware :)

Share this post


Link to post
Share on other sites

How can I update? It can't update past 1.1.5 on iTunes.

you can't update past that firmware because your ipod won't handle the software and such that the new firmware has.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...