Jump to content
Marc

Sound on ubuntu

Recommended Posts

OK linux guys Im stuck. Decided today out of the blue that I was gonna run ubuntu for a month. Why? Because Im a bit of a nut job and though it would be a good idea LOL

 

Anyways, I am having some problems with sound. I have an MAudio Delta Audiophile 2496, which is an excellent card right up to the point you want it on linux apparently. There are no drivers out there that I can find other than open sound which is here http://www.opensound.com/ .. Now these look quite old, and dont seem to work. Therefore I am currently stuck for sound.

 

Any ideas? Thoughts?

Share this post


Link to post
Share on other sites

Hmm...just reformatted a few weeks back after my drive failed and haven't installed this again yet. One sec :)

 

You got the same card then? LOL

Share this post


Link to post
Share on other sites

No I don't, but just reminded me to install it again. Going to give the drivers ago on my card as well.

 

LOL, glad it gave you the reminder :P

Share this post


Link to post
Share on other sites

My sound worked out of the box, sorry for hijacking your thread, back to Marc's issue!

 

No worries. It serves me right for having a production soundcard I guess LOL. I will find an answer somehow :P

Share this post


Link to post
Share on other sites

Dont you have the installation CD?

I remember formatting mycomputer, the sound was build in on the motherboard, so I had to use the Motherboard's CD To get the sound back.

 

LOL if only it was as easy as a motherboard CD. The card I have is a studio production soundcard and they dont actually do drivers for linux at all. Therefore I am stuck looking for third party solutions. Now by the looks of it this has happened in the past, but not sure if I can do so anymore.

Share this post


Link to post
Share on other sites

If anyone else has this problem with the same card, you need to do the following to get sound:

 

Go to terminal and type the following

 

alsamixer

 

Press F6 once you are in the alsamixer and you will be able to change the sound card to audiophile 2496. Once you are in here you need to move across to the channels with the sound level bars and move them up to at least 80%

 

Now exit this and type the following into terminal

 

gksudo gedit /usr/share/alsa/cards/ICE1712.conf

 

Once you have the config file open look for the "front" channel section and make it look like the following

 

ICE1712.pcm.front.0 {
@args [ CARD ]
@args.CARD {
	type string
}
type route
ttable.0.0 1
ttable.1.1 1
slave.pcm {
	type hw
	card $CARD
}
slave.format S32_LE
slave.channels 10

 

Save this and exit terminal. All you have to do now is enter your sound settings by clickgin on the sound icon in your taskbar and clicking sound settings. Once in there select Analog Output. Thats it you should now have sound. If you dont try restarting.

Edited by Marc

Share this post


Link to post
Share on other sites

For anyone else doing this, do not make the edit to the conf file as it will cause a problem with upgrades. I had to revert my back and once the update to the soundcard was done it was fine after the following:

 

Open Alsamixer as stated above. Turn up all the volumes as stated above.

 

BEFORE closing ensure the end value is not set to mm otherwise your soundcard is totally muted at the driver.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...